Deployment Nightmare

Discuss problems installing or using TrackStudio.

Deployment Nightmare

Postby jcoxatonce » Thu Aug 14, 2003 6:38 am

I'm having a terrible time just getting TrackStudio deployed in my Apache 1.3.27/Tomcat 4.1.18 environment running on Solaris 8. I can't get anything but a 404 from the Apache server. It's been so fexing, I'm just sure I've missed something obvious. Help?

I've deployed the TrackStudio.war file to my default webapps directory and have verified that I have autoDeploy="true" for the relevant engine/host in my server.xml. I've put a TrackStudio.xml with the following contents also at the default webapps directory:

<!-- TrackStudio Context -->^M
<Context path="/TrackStudio"^M
docBase="TrackStudio.war"^M
reloadable="true"^M
crossContext="true"^M
debug="4" >^M
<Logger className="org.apache.catalina.logger.FileLogger"^M
directory="logs/trackstudio"^M
prefix="trackstudio." suffix=".log"^M
timestamp="true"/>^M
</Context>^M

And have modified my Apache httpd.conf file to reflect the TrackStudio deployment, ie:

<IfModule mod_webapp.c>
WebAppConnection TomcatWarpConnector warp localhost:8008
WebAppInfo /webapp-info
WebAppDeploy examples TomcatWarpConnector /examples
WebAppDeploy TrackStudio TomcatWarpConnector /TrackStudio
</IfModule>

This all seems basic and correct to me, yet after a long initial pause in my web browser the first time I hit the hostname.com/TrackStudio URL, I get a 404 from the Apache server. The server's error_log indicates that fact:

[Wed Aug 13 20:20:59 2003] [error] [client 192.168.0.220] File does not exist: /usr/local/httpd/html/TrackStudio

I'm even more stumped because the application does seem to be deployed, as is indicated in the trackstudio.*.log files generated by tomcat:

....vast amount of data omitted....
2003-08-13 20:20:52 StandardContext[/TrackStudio]: Posting standard context attributes
2003-08-13 20:20:52 StandardContext[/TrackStudio]: Configuring application event listeners
2003-08-13 20:20:52 StandardContext[/TrackStudio]: Sending application start events
2003-08-13 20:20:52 StandardContext[/TrackStudio]: Starting filters
2003-08-13 20:20:52 StandardWrapper[/TrackStudio:default]: Loading container servlet default
2003-08-13 20:20:52 StandardWrapper[/TrackStudio:invoker]: Loading container servlet invoker
2003-08-13 20:20:52 StandardContext[/TrackStudio]: Starting completed

Looks good. Why can't I seem to get this application deployed when the examples deployed along side it work just fine? I'm baffled, and short on time.

Thanks for any help.
Josh
jcoxatonce
 
Posts: 2
Joined: Thu Aug 14, 2003 6:17 am

Re: Deployment Nightmare

Postby admin » Thu Aug 14, 2003 11:47 am

jcoxatonce wrote:I'm having a terrible time just getting TrackStudio deployed in my Apache 1.3.27/Tomcat 4.1.18 environment running on Solaris 8. I can't get anything but a 404 from the Apache server. It's been so fexing, I'm just sure I've missed something obvious. Help?

I've deployed the TrackStudio.war file to my default webapps directory...


Actuall, this should be enough - Tomcat will unpack WAR and it should be available, I just check it with Tomcat 4.1.12-LE-JDK14

Please try to remove all in /webapps/TrackStudio, left only index.html and WEB-INF/web.xml. Even in this case http://host:port/TrackStudio should be accessible.
Maxim Kramarenko (mailto: maximkr@trackstudio.com)
TrackStudio - Hierarchical Bug & Issue Tracking Software
http://www.trackstudio.com
admin
Site Admin
 
Posts: 8143
Joined: Thu Jan 01, 1970 3:00 am
Location: Smolensk, Russia

Re: Deployment Nightmare

Postby admin » Thu Aug 14, 2003 8:44 pm

jcoxatonce wrote:I'm having a terrible time just getting TrackStudio deployed in my Apache 1.3.27/Tomcat 4.1.18 environment running on Solaris 8. I can't get anything but a 404 from the Apache server. It's been so fexing, I'm just sure I've missed something obvious. Help?


I just download Tomcat 4.1.27/Windows and test TrackStudio 2.7.4 with it - all works fine.
Maxim Kramarenko (mailto: maximkr@trackstudio.com)
TrackStudio - Hierarchical Bug & Issue Tracking Software
http://www.trackstudio.com
admin
Site Admin
 
Posts: 8143
Joined: Thu Jan 01, 1970 3:00 am
Location: Smolensk, Russia


Return to TrackStudio Support

Who is online

Users browsing this forum: No registered users and 6 guests

cron